PimpMyEA Migration to Build 600 – Part 1 9


Hi Everyone,
this is the first one of a series of posts we’ll publish in the coming days for keeping you updated about the compatibility of our products with Build 600 and their eventual migration to the new platform.

We had planned 3 updates to be released this week (HART EA, ForteFX, One4All), but unfortunately they’ll be postponed to next week due to the time we’ve been devoting to MT4 Build 600.

We are also wondering if it is worth sending updates that are compiled on Build 509 or if compiling directly on the new Build 600 is a better option for everyone… that’s why we sent out a poll earlier today and we’d really like to hear your voice in this regard.

Now let’s show the results of our initial testings on Build 600 that fortunately are pretty encouraging :-)

The following Custom Indicators compiled on Build 509 (the same versions that you can find in the respective download areas) have shown to work without issues on Build 600:

  1. PotenzaFX
  2. PowerbarsFX
  3. SintesiFX
  4. DuettoFX
  5. Matrix

Also the following Expert Advisors compiled on Build 509 (the same versions that you can find in the respective download areas) are supported without problems by MT4 Build 600:

  1. ForteFX
  2. OndaFX
  3. OndaFX_Scalper
  4. RenkoLiveCharts
  5. HART EA

And the last news is that we already have the following EAs compiled under MetaEditor Build 600, so they can run “natively” on the new platform and they are indeed running smoothly (opening and closing trades according to their trading logic) so far:

  1. B600_ForteFX
  2. B600_OndaFX
  3. B600_OndaFX_Scalper

We are using the prefix “B600_” for all the source code compiled under Build 600, so it is clear for everyone that these versions can run exclusively (and natively) on Build 600 or higher. We’ll make available these new versions very soon. But before that it is important that you take part in our poll:

POLL: MT4 Build 600 Usage

Your comments are very welcome :-)

 


Leave a comment

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

9 thoughts on “PimpMyEA Migration to Build 600 – Part 1

  • Anthony Cross

    RenkoLiveCharts_pimped_v4 does not function on build 604 as it should.
    on a GBPUSDM1 chart the Renko conversion is made with the chart instruction to open offline
    and select GBPUSD,M2. But there is no M2 option only M30
    Have you found a way to get a M2 Renko chart. The problem is the same with other pairs, not just the GBPUSD.
    Build 509 is no problem.
    Thanks, Tony

  • Anthony Cross

    Further to my earlier email on RenkoLiveChart_pimped_v4, a greater number of Renko chart options such as M1, M5 etc are available if the mt4 build 604 is opened in Portable mode, however the M2 chart is still not on offer.

    The Portable mode allows you to store and record data in the installation folder.
    To use the Portable mode, you need to type the “/ portable” key after the full address. For instance, when you right click on the properties box of the terminal to find the target location, you then type in / portable after the address, Note carefully the single space between / and portable. Any help ?
    Tony.

    • Paolo Post author

      Hi Tony, yes I know the “portable” option, but it should not be necessary for running RenkoLiveCharts on Build600 or higher. I’ll get back to you on this matter asap.

  • Kathrin Runge

    Hi,
    great work. I need nuova indicator for both builds – it cannot install or attach it on Build 600+
    And I am running Reticolo now on B600 – it seems to be ok so far, are there any issues with this EA I should know?
    L, Kathi

    • Paolo Post author

      Hi Kathi, yes I know that NuovaFX and One4All need adjustments for running on Build 600. On the contrary ReticoloFX runs smoothly under Build 600.

  • Mike

    HI,
    I tried to put an old indicator into experts/indictors folder but it just ‘disappeared’!
    Is it possible to use older indicators in build 600?

    Cheers

    • Paolo Post author

      exactly, the “trick” with BUild 600 and higher is to locate the “Data Folder” that is placed outside MT4 installation directory. This folder is accessible via the “File > Open Data Folder” menu 😉